Cut-off mails

Use this forum to get help.

Cut-off mails

Postby Karl-Egon » Tue Sep 01, 2009 11:40 pm

Hello Community!



My mails which I dispatched by means of web mail to recipients which I generated from Spamgourmet or also by answer button, so that answer mail aims at my SG address, is cut off now and again.

These are always pure, uncoded text mails, partly with attachment (.TXT), partly without.
Related to two different Spamgourmet accounts.
But not in every case of Spamgourmet address.

After the receivers complained, I sent in each case identical test mails to myself, while I used a generated Spamgourmet aim address and found the phenomenon confirmed.

If I dispatch the same mail, nevertheless, with the using of Outlook? about POP3 of the same web mail account, they arrive safely and completely.

What can be the reason about that?
Has somebody still made similar observations?
What can be done against the cutting off?

Unfortunately, no support is to be expected from the web mailer.



Regards,

KE
das immernoch etwas andere forum:_________ http://berliner-nachrichten.eu.steingrueber.info/phpBB3/
Karl-Egon
 
Posts: 34
Joined: Thu Oct 12, 2006 11:06 am
Location: SOL-3-EU-DE

Postby josh » Wed Sep 02, 2009 3:40 pm

not sure why something like that would happen - can you PM me an example?
josh
 
Posts: 1371
Joined: Fri Aug 29, 2003 2:28 pm

Re: Cut-off mails

Postby rdigqd » Thu Sep 10, 2009 4:12 pm

Ditto somewhat for me ... with, in my case, emails that
are sent by a local client (EUDORA) rather webmail.

After first noticing this (( around late July) ... and
that it is consistent/repeatable (in that it _always_
happens for the _same_ msg body text when it is re-sent)
... I adopted approach of BCC set to both an 'xoxy.net' id
_and_ to an e-mail that does NOT come back to me via SG,
instead of BCC to the xoxy.net id only.

>>>>>>>>>>>>>>>>
The copy that comes back to me via the non-SG id is
always 100% intact, including attachments.

The one that come back via xoxy.net _is_ truncated.
And, it also seems near 100% of the time that any
attachments to the original msg are gone when it comes
back to me via the xoxy.net id.
>>>>>>>>>>>>>>>>>


No surprise (since I was able to receive an intact copy as
detailed above), but to t-cross and i-dot: apparently, the
outgoing msg is _not_ truncated (as reported by other
recipients of it when I specifically asked them).

This does not happen with every msg I send, but
I am unable to discern any threshold 'triger' (eg: msg body
length, text pattern in the body text, or the like)

Hope this helps track down/isolate the glitch (soon! <G>).

Thruput delays are aggro (but one learns to live with
that occassionally happening with SG during DDOS spells
and so forth); however, when message integrity/complete-
ness is in peril (especially when that occurs unpredictably)
it is a whole much bigger problem.

jim

[quote="Karl-Egon"]
Hello Community!

My mails which I dispatched by means of web mail to recipients which I generated from Spamgourmet or also by answer button, so that answer mail aims at my SG address, is cut off now and again.

These are always pure, uncoded text mails, partly with attachment (.TXT), partly without.
Related to two different Spamgourmet accounts.
But not in every case of Spamgourmet address.

After the receivers complained, I sent in each case identical test mails to myself, while I used a generated Spamgourmet aim address and found the phenomenon confirmed.

If I dispatch the same mail, nevertheless, with the using of Outlook? about POP3 of the same web mail account, they arrive safely and completely.

What can be the reason about that?
Has somebody still made similar observations?
What can be done against the cutting off?

Unfortunately, no support is to be expected from the web mailer.



Regards,

KE[/quote]
rdigqd
 
Posts: 24
Joined: Mon Feb 21, 2005 7:38 pm

Re: Cut-off mails

Postby Karl-Egon » Thu Sep 10, 2009 6:15 pm

Hi Jim!



I'm so happy: I am not alone ... :)

Our varieties:
You used Eudora ? I use Web.de

But our similarities are much more:

rdigqd wrote:The copy that comes back to me via the non-SG id is always 100% intact, including attachments.

Same to me.

rdigqd wrote:The one that come back via xoxy.net _is_ truncated.

Same to me.
Only, I employed SG's domains spamgourmet.com and mycleaninbox.net
? Probably the SG domain is not relevant

rdigqd wrote:And, it also seems near 100% of the time that any attachments to the original msg are gone when it comes back to me via the xoxy.net id.

Same to me.
In the cases of truncating, always the attachement was lost.
? Obviously attachements are located at the end of the message.

rdigqd wrote:[?] to t-cross and i-dot: apparently, the outgoing msg is _not_ truncated

What does this mean?

rdigqd wrote:This does not happen with every msg I send

Same to me.
Only with specific SG addresses and
only with specific mails.

rdigqd wrote:I am unable to discern any threshold 'triger' (eg: msg body length, text pattern in the body text, or the like)

Same to me.
My noticed two cases were truncated at:
    [?] Falscheingabe w?re damit ausger?umt.
    <<<<cut>>>>
    ---
    Ich w?rde diese Antwort dann auch posten. [?]
    But it was the second "---" in the text!
    [?]
    > Du erinnerst Dich also an unser Gespr?ch nach dem Tourauftakt am Freitag.
    <<<<cut>>>>
    > Vielleicht kann ich hier nochmal verdeutlichen, wie ich meine Haltung definiere.
    [?]

    [?] aktiv positionieren kann
    <<<<cut>>>>
    .

    Ich habe mich immer geweigert [?]
    The "." is a very regular character, isn't it?
? Maybe the content is not relevant too ...

What could be a relevant aspect for the problem?



Regards,

KE



Edit: example added
Edit: used SG domains corrected
Last edited by Karl-Egon on Thu Sep 10, 2009 10:19 pm, edited 2 times in total.
das immernoch etwas andere forum:_________ http://berliner-nachrichten.eu.steingrueber.info/phpBB3/
Karl-Egon
 
Posts: 34
Joined: Thu Oct 12, 2006 11:06 am
Location: SOL-3-EU-DE

Postby josh » Thu Sep 10, 2009 6:48 pm

I'm taking the body of the emails PM'ed to me and emailing them from an external account to a xoxy.net address of mine, and not getting the problem. Am I doing that right? Or is this a problem going the other direction?
josh
 
Posts: 1371
Joined: Fri Aug 29, 2003 2:28 pm

Cut-off mails

Postby rdigqd » Thu Sep 10, 2009 7:13 pm

josh,

just now sent you a PM with some detailed data on this problem,
and URL for example TXT files.

jim

[quote="josh"]
not sure why something like that would happen - can you
PM me an example?
[/quote]
rdigqd
 
Posts: 24
Joined: Mon Feb 21, 2005 7:38 pm

Postby Karl-Egon » Thu Sep 10, 2009 8:58 pm

josh wrote:I'm taking the body of the emails PM'ed to me and emailing them from an external account to a xoxy.net address of mine, and not getting the problem. Am I doing that right? Or is this a problem going the other direction?
    PM sent


Josh!


I have no proofs of it, but I think, the problem comes from the interaction of the internal webmailer software with e-mail addresses in the SG format with leading "+".

I remember that sometimes Web.de declares an error if I send one e-mail to several receivers and deplores, I should use a valid e-mail address, while I pasted in the generated address of the SG site without a mistake.

A few years ago, Web.de does not accept e-mail addresses with a dot before "@" as valid ...

But Web.de has many users, we should try to find a solution.

If Jim uses Eudora, he has to send his mails to mail server, or?
Maybe, this mail server's behavior is like Web.de's.


KE
das immernoch etwas andere forum:_________ http://berliner-nachrichten.eu.steingrueber.info/phpBB3/
Karl-Egon
 
Posts: 34
Joined: Thu Oct 12, 2006 11:06 am
Location: SOL-3-EU-DE

Postby Karl-Egon » Mon Sep 21, 2009 1:37 am

It happened again!

Josh,


do you want another example PM?


KE, despairingly
das immernoch etwas andere forum:_________ http://berliner-nachrichten.eu.steingrueber.info/phpBB3/
Karl-Egon
 
Posts: 34
Joined: Thu Oct 12, 2006 11:06 am
Location: SOL-3-EU-DE

Postby josh » Wed Sep 23, 2009 5:35 pm

yes, please


If you can replicate it with a simple test text-only email message, then the full envelop/text of that email message would help a lot.
josh
 
Posts: 1371
Joined: Fri Aug 29, 2003 2:28 pm

Cut-off (truncated) e-mails

Postby rdigqd » Wed Sep 30, 2009 5:12 pm

[quote="josh"]

yes, please

If you can replicate it with a simple test text-only email
message, then the full envelop/text of that email message
would help a lot.[/quote]

...

Recent changes:
1) Over that couple of weeks, this has been happening
a LOT more
(or maybe I just didn't notice it before, until the incidents
beginning in late July that caught my eye cuz stuff I
was looking for in msg copies CC-ed or BCC-ed
to my SG id were truncated.)
2) it is happening on e-mails sent to me
(versus ones that I sent and CC/BCC-ed to myself)

After I noticed the earlier reported problem, I made
some changes in my e-mail sending procedure:
BCC-ing to _both_ the SG id indicated in the
return-addr of the email and to a non-SG e-mail id.

That way, when the msg gets back to me I can easily
see if the one which was processed thru SG is intact
or "chopped".

Now, a "new" behaviour arrives:

One of my other e-mail id's ("public id" provided by a
professional organization) is widely known and so I
auto-FWD it to an SG id, and then that SG id sends
anything that gets past the "trusted sender" scan
back to me at a non-public email id.

For unrelated reasons, some time ago I changed the
settings on that "public id" to auto-FWD to _both_
the SG id and to the non-public id.

In essence, if _two_ copies of a message are received
when I run my e-mail client and do Get-Mail, then the
msg is from a "trusted sender". If only _one_ copy arrives,
I can either ignore/delete it, or use that occurrence to
update my "trusted sender" list.

A key difference in the past weeks or so is that truncation
is happening to e-mails _sent_ to me ... that is, not e-mail
that _I_ sent which was then CC-ed/BCC-ed back to me.

I first noticed this "new" situation after 2009.09.22

To date, I have captured full and "chopped" versions
of 14 messages.

On 2009.09.10, I PM-ed you with a description and
a URL where TEXT-format of the body-and-all-headers
versions of the emails I knew about to that date could
be found.

If these more recent "hits" of this problem will help
you track down the 'gremlin' I can send them too.

==>> were the previous items I sent helpful?

==>> do you want these recent (14x2) items ??

==>> if so, thru what means and in what format??

Lemme know if you want these msgs, and how,
and I'll get them to you ASAP.

Delays from time-to-time in SG thru-put (eg: during spammer
DDOS parties) is just a cost-of-doing-business that loyal SG
users have come to acknowledge, but when the integrity and completeness of email msgs processed thru SG is unreliable
or unpredictable, that fast becomes a worry and potential
show-stopper.

.
.
A passing thought, FWIW
--------------------------------
I have no concrete rationale, only a niggling feeling,
.
.
but I wonder if a change I think was made to SG
probably back towards the start or early part of the
year might somehow be involved.

Back in that time-frame I had a bunch of emails from
"trusted senders" that were eaten or caused the counter
on several of my SG ids to increment (ie: they were not
recognized as "trusted senders").

It took me a while, but eventuallllllly, I managed to track
down and suss out that SG had, it seemed, been changed
to either _start_ using "envelope-from" info, or to use it
as superior to "From Addr" info (when both were present)
for doing the scan.

My investigation found that some folks had changed their
e-mail client, so this info was now presented in the
msgs they sent; for others, it was a change made
by their ISP.

Whatever, that "envelope-from" was now prsent when I
examined their msg headers ... and... the only way these
folks could again be given "trusted sender" treatment was
to add their "envelope-from" info to my list, ... EVEN if it
differered from their real, true, actual "return addr"

Like I said above: no solid rhyme or reason or rationale for
thinking the "truncation" gremlin might be somehow related,
but only a gut feel from past experience and given the timing
that it mebbe-is or mebbe-is-not a coincidence. HTH.

jim
rdigqd
 
Posts: 24
Joined: Mon Feb 21, 2005 7:38 pm

Cut off emails happened to me, too.

Postby gph9 » Wed Sep 30, 2009 5:35 pm

Dear Spamgourmet staff,

I have experimented and found the reason. It happens reproducably every time there is single . at the beginning of a line.

Are you piping messages through sendmail or something similar?

In case you need further information, I can provide test cases. I am a Perl programmer and have experience with mail messaging and the relevant RFCs.
gph9
 
Posts: 1
Joined: Wed Sep 30, 2009 2:12 pm

Cut off emails happened to me, too.

Postby rdigqd » Thu Oct 01, 2009 9:41 pm

"gph9" puts forward an interesting hypothesis.

I went a checked some (half-a-dozen or so) of the 30+
truncated/non-truncated msg pairs I have saved here (as
per my 2009.09.30/12:12 post) and found a very interesting
situation ...

The character in them that marks the break-point
where the truncation occurs is a "."

--> the truncated messages ALL end _precisely_ at the 2nd-last
character of a line ... the FINAL character of which is a "."

No other commonality that I can see/intuit in terms of length
of original msg, internal structure of the msg (at least none
that jumps out at my eye), how far into an e-mail before this truncation occurs, etc.

But it is truly bizarre that the final "." of that line and
everything that follows is truncated/deleted in the copy of
the incoming (to me) msg that went thru SG on its way to
my In-Box versus an identical copy that did not go thru SG.

Next thing to check???

jim
rdigqd
 
Posts: 24
Joined: Mon Feb 21, 2005 7:38 pm

Cut-off mails [subject should be "truncated emails&quo

Postby rdigqd » Tue Jan 05, 2010 9:31 pm

Josh,

after a lull ... or at least a slowing in frequency of occurence ...
the mail truncation thing is happening again, with a VENGEANCE.

I have captured the full and truncated version of
each of 65 msgs where I have managed to set up
some of my email ids so it automatically sends rec'd
msgs both directly to me and to the appropriate
one of my SG ids.

When the msg came to me directly, it is intact and Ok.
When it goes thru SG before hitting my in-box, the
truncation occurred ... at a line that ended with a "." as
I said to you in my msg on this thread (t-1245) dated
Oct 1, 2009. ((you should revisit that entry for the details))

Does this happen with every single incoming message?
No
But, in every single 'truncated' msg, the lop-off
point is on a line that ends with a "."

As well, ... if the incoming msg had any File Attachments,
those are 'disappeared' too.

... Do you want the text of these emails sent to you
... so you, Syskroll, etc. can mebbe figger out wazzup
... and fix it??

If so, how (by what means) and in what format??

jim

________________________________
rdigqd
 
Posts: 24
Joined: Mon Feb 21, 2005 7:38 pm

Postby Karl-Egon » Wed Jan 06, 2010 1:57 am

Hello Jim! Hello Josh!



I noted that phenomenon in several e-mails in the past.

The point is '.' if it stands at the end of a line at the moment of its trip through SG.
If you use continuous text, the line breaking is dependent from the width of the window, or the defined number of characters per line.

The sender does not know how (and from where) to count the number of characters, must not be '.'
Unfortunately, we finish our sentences with '.', there remains only one unhappy chance ?

But: the problem is, SG truncates.
The problem is not as long lines can be!



Many regards to a new decade,

K-E
das immernoch etwas andere forum:_________ http://berliner-nachrichten.eu.steingrueber.info/phpBB3/
Karl-Egon
 
Posts: 34
Joined: Thu Oct 12, 2006 11:06 am
Location: SOL-3-EU-DE

Please do not ignore the old problem!

Postby Karl-Egon » Thu Mar 11, 2010 8:51 pm

Hi Josh, Syskoll, Team of SG!


Will there be in the foreseeable future a solution for the problem with the cut emails?

Or does the only chance consist in finding an alternative to SG?

The topical situation is intolerable on a continuing basis!


PLEASE HELP!



Regards,

Karl-Egon
das immernoch etwas andere forum:_________ http://berliner-nachrichten.eu.steingrueber.info/phpBB3/
Karl-Egon
 
Posts: 34
Joined: Thu Oct 12, 2006 11:06 am
Location: SOL-3-EU-DE

Next

Return to Support / Hilfe / ayuda / ondersteuning / ...

Who is online

Users browsing this forum: No registered users and 4 guests

cron